Rebuild on 861

Case number:699969-997292
Topic:General
Opened by:brow42
Status:Open
Type:Bug
Opened on:Friday, March 21, 2014 - 04:26
Last modified:Friday, March 21, 2014 - 21:10

In most puzzles, there's always some helix that won't rebuild. In a recent puzzle it was part of the puzzle-specific setup. But it happens all the time.

In 861 I made a big helix and it just won't rebuild. If I use tweak, it stops tweaking before it's straight. When I got it mostly correct, tweak bent it 90 degrees and then stopped.

Maybe there's something wrong with the puzzle setup again. Or maybe there's something fundamentally wrong in your resources.

I've shared a solution to 861 called Helix rebuild. I'd like you to try rebuilding, tweaking, and wiggling 34-40 EQVHILY. If you can find out why these won't rebuild or tweak into a helix, perhaps you can fix the entire problem.

I'm playing in main client 20140213-f6ad820032-win_x86.

(Fri, 03/21/2014 - 04:26  |  3 comments)


bkoep's picture
User offline. Last seen 1 day 6 hours ago. Offline
Joined: 11/15/2012
Groups: None

Thanks for the share, brow. It looks like there are a few peptide bonds in your helix with REALLY bad geometry (in the stick view screenshot below, you can see the sharp acute angle in the amide group, which should have an angle closer to 125 degrees).

You can fix those bonds with the idealize tool; the helix behaves well for me after that. However, this kind of thing really shouldn't happen in the first place, and even when it does, medium and high power wiggle should usually be able to do something about it.

Can you tell us any more about how you developed this solution? Did you open and close a lot of cut-points? What scripts have you run? It see a handful of bad peptides among residues 34-49 in your shared solution.

brow42's picture
User offline. Last seen 3 weeks 2 days ago. Offline
Joined: 09/19/2011
Groups: None

I did extend the fragment before sharing, that could be the origin of the really bad angle. I didn't try idealize. I'm not really used to using that because it moves everything around, but there's no reason not to use it in the early stages. I'll remember that in the future.

But you see that no combination of rebuild, tweak, or wiggle on high is fixing the bad angle. I really can't see why tweak would stop working prematurely on such a short fragment with two free ends. And as you note, high wiggle should have fixed it anyways.

I started this puzzle by setting 47 to helix, freezing 26, and then rebuilding for several minutes. It consistently refused to rebuild a non-helix portion at the low end. I tried tweak, but it wouldn't budge. I used a band and the pull tool to pull the loops of the helix together and again tried to rebuild. It produced a not-quite straight helix, with multiple mild kinks. I ran tweak, but it would stop right away (it seems to be holding 57 as a fixed end). I cut at 27 and it bent it 90 degrees near the original bad spot, then stopped. I aggressively banded i to i+4 for several turns and rebuilt...I ended up with a sort-of pi helix in the middle, so maybe my banding was wrong (but the bands looked colinear with the alpha part. It seemed the turns were too close together and clashing, and slightly larger radius, than an actual alpha-helix). I ran tweak, but again it did not do anything and did not fix the pi helix. I removed the bands and rebuilt and this fixed the pi-helix, but the bad spot in the 30s remained. At this point I cut out the bad spot and just tried to fix the fragment. Rebuild would never fix the kink in the end segments, and tweak would always unravel the helix part way and then stop. I lengthened the fragment on each end to see if that changed how rebuild treated the end fragments, and after a while I gave up and shared the solution.

I've tried to reproduce this in a few resets but now it seems to be working. I was just unlucky. I didn't think to use idealize. But you agree that tweak-rebuild-high wiggle should have fixed it. This shows how a solution can get stuck in a rut, either by chance or using cutpoints, that the pre-idealize tools simply refuse to fix.

bkoep's picture
User offline. Last seen 1 day 6 hours ago. Offline
Joined: 11/15/2012
Groups: None

Hmm, my best guess is that there is some bad closure happening in Rebuild. jflat posted a devprev update today that addresses a Rebuild bug that could be related. I know you said you're playing in a main client, but please let us know if this continues to happen—especially if you try the devprev update.

Sitemap

Developed by: UW Center for Game Science, UW Institute for Protein Design, Northeastern University, Vanderbilt University Meiler Lab, UC Davis
Supported by: DARPA, NSF, NIH, HHMI, Amazon, Microsoft, Adobe, RosettaCommons