If current games require latest client, please then also make latest client available as download.

Case number:671071-996323
Topic:Game: Other
Opened by:Bletchley Park
Status:Open
Type:Suggestion
Opened on:Tuesday, November 19, 2013 - 21:16
Last modified:Tuesday, November 19, 2013 - 22:26

I am in a hotel right now with a slow connection. I cannot log on to the game. I decided I download the LATEST client so I could see if that remedied the problem. It turned out to be a slightly older version. So I installed that, then it turns out I need a newer version to play the latest puzzles...

And the whole download starts again through the client...

Please make the latest version required to play the game the default for download.

(Tue, 11/19/2013 - 21:16  |  1 comment)


beta_helix's picture
User offline. Last seen 2 hours 56 min ago. Offline
Joined: 05/09/2008
Groups: None

That is a great suggestion.
Thank you for bringing this up, BP!

Sitemap

Developed by: UW Center for Game Science, UW Institute for Protein Design, Northeastern University, Vanderbilt University Meiler Lab, UC Davis
Supported by: DARPA, NSF, NIH, HHMI, Amazon, Microsoft, Adobe, RosettaCommons