Loosing sound when running Foldit

Case number:699969-993856
Topic:General
Opened by:Timo van der Laan
Status:Closed
Type:Bug
Opened on:Wednesday, November 7, 2012 - 00:53
Last modified:Thursday, December 6, 2012 - 19:22

Very strange, when I am running Foldit (with sound OFF) somehow the speakers on my laptop stop functioning.
Running Windows 7 64 bit. On my other laptop (windows 7 32 bit) I have no problem. When I stop running Foldit the problem disappears. And the sound gets blocked when a V2 recipe calls wiggle, NOT before that.
Happens in main and devprev.

(Wed, 11/07/2012 - 00:53  |  9 comments)


Joined: 09/21/2011
Groups: Void Crushers
Status: Open » Closed

Found a way around it, had to give the audio program high performance priority.

Joined: 09/21/2011
Groups: Void Crushers
Status: Closed » Open

Too early thought I solved it, it still happens that sound is blocked while running Foldit. However cant pinpoint it.

Joined: 11/06/2012

do you know if skype is running at all? skype somehow seems to make a way for audio to get through windows even if it is muted. I'm not certain, but its certainly a problem with me.

tamirh's picture
User offline. Last seen 6 years 10 weeks ago. Offline
Joined: 05/11/2012

I'll look into this.

tamirh's picture
User offline. Last seen 6 years 10 weeks ago. Offline
Joined: 05/11/2012

I haven't yet gotten this to repro on my x64 win7 machine.

Have you checked to see if there are any new drivers for your sound card and/or your motherboard if you have an onboard sound card?

Joined: 09/21/2011
Groups: Void Crushers

I am still investigating. Suspision, not really confirmed is that somehow in devprev it says to the soundcard/mixer put all sounds off. Immediately after I stop all foldit clients sound is back. Will try a workaround (putting sound on but saying to the mixer 1% to all Foldit clients) and report the findings.

Joined: 09/21/2011
Groups: Void Crushers

I have done a lot of testing now. Running with sound ON the sound stops rather quickly when I run my DRW program.
Puzzles 649, 650. Log file of one of the tests is attached.
It looks like it is trying to send the next sound while the previous has not stopped yet. (When I hear a sound being cut off, all sounds are gone)
I even tried restoring the system to the situation a month ago, did not help. The problem is in main and in devprev.

System: Windows 7 64 bit, Conexant Smart Audio HD mixer.
What I do not understand is why Foldit speaks to the audio system when sounds are set off.

tamirh's picture
User offline. Last seen 6 years 10 weeks ago. Offline
Joined: 05/11/2012

The only thing I can see in the code that may be an issue is that even if the music is off, Foldit will still request to 'turn off sound' when background music stops. The driver should ignore this because there's no sound running, but I can see it possibly causing an issue.

I've modified the code so it doesn't do this. This should go out in the next version of devprev.

Joined: 09/21/2011
Groups: Void Crushers
Status: Open » Closed

Tamir, sorry I just noticed sound disappearing while not running Foldit. Closing the case.
So it must be some windows problem.

Sitemap

Developed by: UW Center for Game Science, UW Institute for Protein Design, Northeastern University, Vanderbilt University Meiler Lab, UC Davis
Supported by: DARPA, NSF, NIH, HHMI, Amazon, Microsoft, Adobe, RosettaCommons