Crash after NANs occured in hbonding

Case number:699969-993740
Topic:General
Opened by:truestone
Status:Open
Type:Bug
Opened on:Saturday, October 13, 2012 - 19:52
Last modified:Wednesday, October 17, 2012 - 17:49

When running my script ID 44308 on Platypus Venom, foldit crashes after about 5 mins. The log ends with several messages "core.optimization.LineMinimizer: Inaccurate G! " (which occur all over the place), followed by these lines (in 5 out of 6 cases):

core.scoring.NeighborList: Minimization stats: 23 score/deriv cals, 0 narrow-from-wide updates, 0 full updates.
Hbond tripped: [2012-10-13 21:32:37:]
core.scoring.hbonds: NANs occured in hbonding!
UNHANDLED EXCEPTION
[rather anonymous stack trace and Autosaved chatter suppressed]

or followed by this in one of six cases:

core.scoring.NeighborList: Minimization stats: 20 score/deriv cals, 0 narrow-from-wide updates, 0 full updates.
sin_cos_range ERROR: 1.#QNAN00 is outside of [-1,+1] sin and cos value legal range
sin_cos_range ERROR: 1.#QNAN00 is outside of [-1,+1] sin and cos value legal range
ERROR:: Exit from: D:\jflat06\foldit\mini-interactive-main-alt\rosetta_source\src\numeric/trig.functions.hh line: 117
ERROR: Rosetta exit unexpectedly

This on devprev, Windows XP 32-bit.

(Sat, 10/13/2012 - 19:52  |  6 comments)


tamirh's picture
User offline. Last seen 6 years 17 weeks ago. Offline
Joined: 05/11/2012

Could be related to http://fold.it/portal/node/993664 -- I'll look into it

tamirh's picture
User offline. Last seen 6 years 17 weeks ago. Offline
Joined: 05/11/2012

Do you have a particular solution file you load first and this happens? Starting from the initial puzzle running your script doesn't seem to trigger any crashes. I'm still running it, I'll update if something happens.

Joined: 03/18/2012
Groups: Gargleblasters

Sorry, was distracted. It happens on the best scoring (i.e. 8803) puzzles at my disposal, lately the one I shared under the name "evo v3.3". The crash really happens within less than a minute. It happens when "WiggledSelected" is the last command displayed with "Show script commands" enabled, but that should come as no suprise since wiggle is all the recipe does.

Joined: 03/18/2012
Groups: Gargleblasters
Type: Suggestion » Bug

And I forgot to mention it also happens on an entirely different piece of hardware and OS, a Windows 7 x64 box. Same log message too, I checked.

Joined: 03/18/2012
Groups: Gargleblasters

Indeed it's the solution that is the problem. It crashes quicker now because my starting solution is closer to the protein-of-death.

In fact, I just saved and shared a solution called "evo v3.4" that crashes without recipe, simply by pressing E in the original interface.

tamirh's picture
User offline. Last seen 6 years 17 weeks ago. Offline
Joined: 05/11/2012

Thanks, I'll check it out. It sounds like the same bug (the one bertro was running into was not OS specific) but I'll make sure.

Sitemap

Developed by: UW Center for Game Science, UW Institute for Protein Design, Northeastern University, Vanderbilt University Meiler Lab, UC Davis
Supported by: DARPA, NSF, NIH, HHMI, Amazon, Microsoft, Adobe, RosettaCommons