unknown residue type ".

Case number:954892-993636
Topic:Developer Preview
Opened by:doug.ehlert
Status:Open
Type:Bug
Opened on:Sunday, September 30, 2012 - 20:40
Last modified:Monday, January 14, 2013 - 21:40

I've been getting this error with increasing frequency. Currently running latest linux devprev.

The solution saves without error, but when I try to load or share it, I get this error and the solution does not load. Currently I can't load my solutions for puzzles 634 and 635.

After backing out to older solutions that do load, I get the same error after gaining points.

(Sun, 09/30/2012 - 20:40  |  11 comments)


Joined: 05/19/2009
Groups: Contenders

tamirh found a bug while checking for 633, he writes in that thread: "Found out what was causing the "Invalid residue found" issue, that will be fixed in the next devprev push."
Hopefully it is the same issue.

beta_helix's picture
User offline. Last seen 7 hours 29 min ago. Offline
Joined: 05/09/2008
Groups: None

assigning...

tamirh's picture
User offline. Last seen 6 years 10 weeks ago. Offline
Joined: 05/11/2012

Unfortunately it wouldn't be the same issue. I'll look into this. Thanks for finding it.

tamirh's picture
User offline. Last seen 6 years 10 weeks ago. Offline
Joined: 05/11/2012

could you share one of your broken solution files with me?

tamirh's picture
User offline. Last seen 6 years 10 weeks ago. Offline
Joined: 05/11/2012

or better yet, let me know if there are any particular steps that seem to result in the corrupted save files.

Joined: 09/21/2011
Groups: Contenders

The solution with an error is attached.

Joined: 09/21/2011
Groups: Contenders

This happened to me again last night on puzzle 639 with last version of main. I've just switched to the new version.

Joined: 09/21/2011
Groups: Contenders

Happened again on 639 with the latest version of main.

Joined: 09/21/2011
Groups: Contenders

I loaded into a new directory (running main), only copying my old solutions through sharing. Two days later, I just got exactly the same error. In this case, my current score is 1192 but the highest scoring solution I can see is 1135.

In general, is the linux support just buggy? I ask, because I see tons of bugs in linux (more than one box, more than one distro) that I don't see in Windows (both XP and 7).

Is there an expectation that the two are equally supported?

Joined: 09/21/2011
Groups: Contenders

Same error last night on puzzles 667 and 668.

tamirh's picture
User offline. Last seen 6 years 10 weeks ago. Offline
Joined: 05/11/2012

It looks like I may have a case where I can reproduce this on the 'beta: symmetry with layerscore filer test'. I'm looking into it further and hopefully I can get it to reproduce again.

As far as the linux release, it doesn't get as much coverage versus the other platforms because there are less people using it but it's no less supported. Most of us developers who are working on Foldit actually use Linux so unless it's a distro specific issue (which there are some) it should be addressed by us.

Sitemap

Developed by: UW Center for Game Science, UW Institute for Protein Design, Northeastern University, Vanderbilt University Meiler Lab, UC Davis
Supported by: DARPA, NSF, NIH, HHMI, Amazon, Microsoft, Adobe, RosettaCommons