Autosave files disappeared, lost high scores

Case number:671071-993003
Topic:Game: Other
Opened by:Timo van der Laan
Status:Closed
Type:Bug
Opened on:Monday, June 18, 2012 - 22:34
Last modified:Tuesday, September 11, 2012 - 09:55

Today I had to stop my laptop (keyboard input and mouse gave no reaction).
However the clients were still running.

So I restarted, and restarted devprev, puzzle 580. The score on the track, were the script had long finished, was very low, so I tried to open the autosaves. There was one score in slot 7, 20 points below the highest score, and all the other autosaves were very recent and very low.

Restarted main, went to puzzle 576, also very low. Checked the autosaves, there was only 1 autosave (also slot 7) and on that puzzle I lost also 20 pts.

The previous high scores were sent to the server, but the autosaves were gone.

The third track was allright no problem there.

Running Windows 7 64-bit.

(Mon, 06/18/2012 - 22:34  |  8 comments)


Joined: 09/21/2011
Groups: Void Crushers
Topic: General » Game: Other
Type: Suggestion » Bug

changed type

jflat06's picture
User offline. Last seen 8 hours 22 min ago. Offline
Joined: 09/29/2010
Groups: Window Group

If the game was attempting to write to the autosave files when you rebooted, they may have become corrupted, which would explain this behavior.

Joined: 09/21/2011
Groups: Void Crushers

Then I would suggest that before writing the creditbest solution, it should be renamed to a backup name.
That one should be permanent until the next write action is due.
But maybe even that wouldn't help if windows 7 has a lazy buffered write to disk strategy.

tamirh's picture
User offline. Last seen 6 years 10 weeks ago. Offline
Joined: 05/11/2012

Assigning to myself, I'll look into making the autosave safer.

tamirh's picture
User offline. Last seen 6 years 10 weeks ago. Offline
Joined: 05/11/2012
Status: Open » Closed

committed fix, should be in the next devprev

Joined: 09/21/2011
Groups: Void Crushers
Status: Closed » Open

It happened again. Lost my high score on 603 and also in the other client that ran 601 the high score was gone. In 601 there was a quicksave 3 solution that had the high, no such luck on 603.
ALL normal savefiles had a low score.

Windows 7 4 quad laptop, 64 bit, running main.

I had to stop the laptop because it hang.

My conclusion: the extra safeguard did not work, maybe there was interference between the different clients.
Or can it be that after a restart the safeguard is discarded?

Joined: 09/21/2011
Groups: Void Crushers

Not only at restart the safeguard should work, but also when entering another track.

Joined: 09/21/2011
Groups: Void Crushers
Status: Open » Closed

Closed because the extra availability of save files helps to keep the highest score.

Sitemap

Developed by: UW Center for Game Science, UW Institute for Protein Design, Northeastern University, Vanderbilt University Meiler Lab, UC Davis
Supported by: DARPA, NSF, NIH, HHMI, Amazon, Microsoft, Adobe, RosettaCommons