3 replies [Last post]
Joined: 10/08/2010

Hi everyone,

I recently updated my Ubuntu 10.04 64-bit system and started getting the following error when trying to start Foldit:

Foldit Error: The game has previously not started up correctly.
If this problem persists, please install the latest version.
freeglut ERROR: Internal error in function fgOpenWindow
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 4 (X_DestroyWindow)
Resource id in failed request: 0x0
Serial number of failed request: 30
Current serial number in output stream: 33

Some potentially graphics related packages that were installed with the update are:
xserver-xorg-core (1.7.6-2ubuntu7.5, 1.7.6-2ubuntu7.6), xserver-common (1.7.6-2ubuntu7.5, 1.7.6-2ubuntu7.6), xserver-xorg-dev (1.7.6-2ubuntu7.5, 1.7.6-2ubuntu7.6), xvfb (1.7.6-2ubuntu7.5, 1.7.6-2ubuntu7.6), ia32-libs (2.7ubuntu26, 2.7ubuntu26.1)

Does anyone have any ideas on how to fix this? It was previously working fine.

Thanks!

Keith

Joined: 06/17/2010
freeglut ERROR

follow that. Get 32 and 64 bit version. Foldit is 32 bit and need mostly 32 bit libraries.

Joined: 10/08/2010
I have installed the 32-bit

I have installed the 32-bit versions of freeglut3 and freeglut3-dev. And I have the ia32-libs, etc installed. I still get the same error.

When I install the 32-bit versions, a separate piece of software (PyMOL) that I compiled with 64-bit libraries stops working (it gives a ELF class error), so I can tell that the 32-bit version has an effect.

Joined: 06/17/2010
Maybe

graphics drivers? I have not so fresh ATI (HD4650) and lots of issues on linux.

Sitemap

Developed by: UW Center for Game Science, UW Institute for Protein Design, Northeastern University, Vanderbilt University Meiler Lab, UC Davis
Supported by: DARPA, NSF, NIH, HHMI, Amazon, Microsoft, Adobe, RosettaCommons