scripted local rebuilds dead?

Case number:954892-987342
Topic:Developer Preview
Opened by:Madde
Status:Closed
Type:Bug
Opened on:Wednesday, February 17, 2010 - 15:38
Last modified:Thursday, February 18, 2010 - 19:49

I ran a LUA script with local rebuilds on few segments of puzzle BETA Alignment (new interface) and the local rebuilds did absolutely nothing. Manual rebuilds worked fine though.

(Wed, 02/17/2010 - 15:38  |  7 comments)


Joined: 11/10/2007
Groups: Window Group
Status: Open » Closed

You are correct, and this should be fixed in an update to the developer preview shortly.

Joined: 11/10/2007
Groups: Window Group
Status: Closed » Closed

That update has been posted to the developer preview.

infjamc's picture
User offline. Last seen 3 days 2 hours ago. Offline
Joined: 02/20/2009
Groups: Contenders

Sorry for recycling this case instead of opening a new one... but since it's another bug specific to the developer review, I'll put it here.

The exploration graph also seems to be broken in the developer review. For example, here's my structure in the recent QttN puzzle-- despite that it is almost a perfect fit minus a helix and the loops at the two termini, the exploration graph still thinks that it's far off (see attachment-- I would expect my solution to be close to those clump of points about 1/4 the way from the x-axis, i.e. my earlier solutions under teh stable build).

Madde's picture
User offline. Last seen 2 years 19 weeks ago. Offline
Joined: 05/29/2008
Groups: Void Crushers

In general: The exploration map doesn't show how far away your solution is from the guide but from your starting structure (which was an extended chain).
Especially this case: Maybe the exploration map of the DP uses a new (better) algorithm. Seth? Anyone?

Joined: 11/10/2007
Groups: Window Group
Status: Closed » Open

Reopening.

Joined: 11/10/2007
Groups: Window Group
Status: Open » Closed

Madde is correct, the exploration map shows the distance from the starting structure, not the guide, so this makes sense. I also checked the map in the DP against the one in the main release and they match, so it seems like nothing has changed.

infjamc's picture
User offline. Last seen 3 days 2 hours ago. Offline
Joined: 02/20/2009
Groups: Contenders

I already know know that the exploration map is showing the distance from the starting structure rather than the guide.

What I found strange, however, is that improving my previous solutions in the 9300s to 9400 would somehow increase rmsd by a factor of 4-- my past experience suggests that this is highly unlikely. To put it another way, the fact that the clump of green dots didn't start showing up until I switched to the developer preview was what seemed like a bug to me. I wonder if that's an artifact of switching versions...

(I would have preferred to reload my solution in the stable build to test my hypothesis, i.e. to see if the graph fixes itself. Unfortunately that's not possible since the solutions aren't backward-compatible...)

Sitemap

Developed by: UW Center for Game Science, UW Institute for Protein Design, Northeastern University, Vanderbilt University Meiler Lab, UC Davis
Supported by: DARPA, NSF, NIH, HHMI, Amazon, Microsoft, Adobe, Boehringer Ingelheim, RosettaCommons