Official GNU/Linux runtime requirements!

Case number:699969-2006240
Topic:General
Opened by:progenyx
Status:Open
Type:Suggestion
Opened on:Monday, November 26, 2018 - 13:45
Last modified:Monday, November 26, 2018 - 13:45

May I humbly suggest that you start maintaining a page listing all runtime dependencies for the GNU/Linux platform. As you're probably aware, this operating system comes out in a multitude of flavors and configurations.

From what I could find debuging your work so far, there are kernel options that should be enabled as well as packages that should be installed.

So, such a list should contain:

1. XClip -- enables the pasting of long passwords in the login menu and most importantly, it doesn't come installed by default on most systems. (you can't go suggesting to people to chose long passwords and then deprive them of the means to input those long passwords, now can you?)

2. CONFIG_SND_OSSEMUL=y and CONFIG_SND_PCM_OSS=y need to be set in the kernel config as these two options enable the /dev/dsp character device used by Foldit. Again, these two options are disabled by default on most general purpose kernels out there.

I'm sure there are others that only you could point to.

(Mon, 11/26/2018 - 13:45  |  0 comments)


Sitemap

Developed by: UW Center for Game Science, UW Institute for Protein Design, Northeastern University, Vanderbilt University Meiler Lab, UC Davis
Supported by: DARPA, NSF, NIH, HHMI, Amazon, Microsoft, Adobe, RosettaCommons