Rama map not showing accurate color areas since recent update

Case number:671071-2003926
Topic:Game: Other
Opened by:Susume
Status:Open
Type:Bug
Opened on:Sunday, July 9, 2017 - 15:09
Last modified:Saturday, July 15, 2017 - 17:32

Since one of the recent devprev updates, the rama map sometimes shows huge color areas that are much bigger than the "desired" areas for each amino acid. I have found a way to cause it, but no way to fix it other than close the client and restart. Changing puzzles does not fix it.

sample crazy rama maps:
http://fold.it/portal/files/chatimg/irc_341210_1499611742.png
http://fold.it/portal/files/chatimg/irc_341210_1499611759.png

To cause problem:
Open a design puzzle. Open rama map - should be normal. Type shift-A to display all sidechains. Rama map goes crazy. Once the problem appears in a design puzzle, it remains if you switch to a non-design puzzle, but I have not been able to cause it to start in a non-design puzzle.

I am seeing this both in build 20170620-a0c2bbb6d0-win_x86-devprev (in puzzle 1395) and in build 20170705-a873005193-win_x86-devprev (in 1401).

(Sun, 07/09/2017 - 15:09  |  5 comments)


actiasluna's picture
User offline. Last seen 3 hours 7 min ago. Offline
Joined: 03/05/2015
Groups: Gargleblasters

I see this in the Monomer puzzles only.

actiasluna's picture
User offline. Last seen 3 hours 7 min ago. Offline
Joined: 03/05/2015
Groups: Gargleblasters

I see this in the Monomer puzzles only.

bkoep's picture
User offline. Last seen 4 hours 42 min ago. Offline
Joined: 11/15/2012
Groups: None

Thanks for pointing this out! It seems to be just a visualization bug in the Rama Map and shouldn't affect scoring or any other tools. I have a rough idea of what's going on, but I'll have to dig a little bit to find a fix.

Merf's picture
User offline. Last seen 17 min 55 sec ago. Offline
Joined: 01/01/2010
Groups: None
Topic: Game: Display » Game: Other

A new!!! bug!!! Just when I thought Foldit couldn't surprise me
anymore, I found this bug: whenever I select "Restore Very Best, I get
the protein with cuts every couple of fragments, as though I had just
selected "Cut and Wiggle Everything" I've tried logging off and back on
but it persists. Anyone come across this before?

Merf.

Merf's picture
User offline. Last seen 17 min 55 sec ago. Offline
Joined: 01/01/2010
Groups: None

I should add, this is puzzle 1404.

Merf.

Sitemap

Developed by: UW Center for Game Science, UW Institute for Protein Design, Northeastern University, Vanderbilt University Meiler Lab, UC Davis
Supported by: DARPA, NSF, NIH, HHMI, Amazon, Microsoft, Adobe, RosettaCommons