Drug Design puzzle loses best score after crash

Case number:954892-2001502
Topic:Developer Preview
Opened by:Susume
Status:Open
Type:Bug
Opened on:Tuesday, November 24, 2015 - 03:19
Last modified:Thursday, November 26, 2015 - 03:25

Have had 2 crashes when clicking C or N in ligand design menu, but can't reproduce at will.

After each crash, on restarting the client, the ligand appears outside the protein instead of inside it, despite the fact that I never moved it outside the protein. Saved this pose and shared with scientists as "save1 ligand outside".

After each crash, restore absolute best and restore credit best do not change the protein or the score. I am unable to get my high score back.

(Tue, 11/24/2015 - 03:19  |  12 comments)


Joined: 01/12/2015
Groups: None

Hi Susume,

Thank you for this information! Do you know which atoms you clicked on when you changed it to C or N? Was it a hydrogen or a heavy atom?

Susume's picture
User offline. Last seen 1 week 4 days ago. Offline
Joined: 10/02/2011

I did not have hydrogens displayed, so I assume it was always a heavy atom. Unless it is possible to select a hydrogen without knowing it when they are not displayed - no idea how to test for that.

Susume's picture
User offline. Last seen 1 week 4 days ago. Offline
Joined: 10/02/2011

This is not just after a crash. After an orderly shutdown and restart, the ligand appears outside the protein instead of where I left it, and I cannot recover credit best or absolute best. Under Open/Share, autosaves, both my absolute best and credit best appear in the list with scores of 9794, but when I attempt to load them they do not load (although the popup says "solution loaded") and the score stays at -81K.

Win 7 build 20151104-151520ae39-win_x86-devprev

Susume's picture
User offline. Last seen 1 week 4 days ago. Offline
Joined: 10/02/2011

Actually after displaying the hydrogens (using stick+H view), I find that I can't select an H to change it. When I click an H, it either does nothing, or selects the heavy atom that the H is attached to.

Joined: 01/12/2015
Groups: None

Awesome. Thank you for the report Susume and I am sorry for the frustrations. Before you closed the game, did you move the ligand away from the binding pocket?

Susume's picture
User offline. Last seen 1 week 4 days ago. Offline
Joined: 10/02/2011

I just rotated it a tiny bit and slid it a tiny bit to the side - nowhere near moving it out of the pocket. Not sure if there was a puzzle reset in between doing that and the moves that resulted in crashing.

Joined: 01/12/2015
Groups: None

I wonder if I put too much of a penalty on the ligand center filter. I will try and reproduce this failure.

Susume's picture
User offline. Last seen 1 week 4 days ago. Offline
Joined: 10/02/2011

Reached a new high score and saved protein. Opened a new client (without closing old one). Protein loads with ligand mostly outside protein and score of -39K. Loaded the new save (which shows in list with score of 9814). Popup says "solution loaded" but protein does not change and score stays at -39k. Hit A to restore best - it stays at -39k.

Went back to first client. Loaded the manual save marked 9814 - it loads at -39k. Hit A to restore best, and it goes back to 9814. So in the client that has stayed open, absolute best loads correctly but the manual save doesn't. In the newly opened client, both absolute best and the manual save are wrong. Both are using default track.

Joined: 09/21/2011
Groups: Void Crushers

So you can conclude that the absolute best in memory is not equal to the absolute best stored on disk, OR that loading or writing something from/to disk is not doing a good job. My 2 cents.

gitwut's picture
User offline. Last seen 41 weeks 4 days ago. Offline
Joined: 05/18/2012
Groups: Contenders

I'm experiencing the same. I closed the ligand Viewing Options window and couldn't get it to reappear, so I saved the puzzle, opened a new client and tried to load the puzzle I saved. The ligand is outside the protein and the loaded score shows as -81015.411. I was also using the default track.

Joined: 06/06/2013
Groups: Gargleblasters

I stupidly closed the client on my windows machine after saving my exciting score of 9758, obtained by nothing I understand. opened and can not reload save and like gitwut, my ligand is haging out outside the protein. also, now everytime I wiggle sidechains the whole ligand seems to move through space like the Gargleblaster spaceship! Third, every time I move or change anything, I have to reset the sliders after each shake, wiggle or other move to see the grid (but thanks to Susume I found the grid).
Lost in space
Skip

Susume's picture
User offline. Last seen 1 week 4 days ago. Offline
Joined: 10/02/2011

I banded both the protein and the ligand in place (zero length bands to space), closed the game and re-opened, and can tell by the bands that the protein did not move but the ligand did. So the game successfully saved and loaded the protein position and the band endpoints but garbled the ligand position during saving or loading.

I moved the ligand to various spots outside the protein, banded it there and closed and re-opened the game. The ligand keeps moving back to the same place (same score), but the band endpoints are wherever I left them. Moved the protein backbone, closed and re-opened; protein stays where I put it while ligand moves back to its usual weird place.

Sitemap

Developed by: UW Center for Game Science, UW Institute for Protein Design, Northeastern University, Vanderbilt University Meiler Lab, UC Davis
Supported by: DARPA, NSF, NIH, HHMI, Amazon, Microsoft, Adobe, RosettaCommons