strange things on 1115 (scoring, autosave)

Case number:699969-2000975
Topic:General
Opened by:LociOiling
Status:Closed
Type:Bug
Opened on:Thursday, July 23, 2015 - 08:12
Last modified:Tuesday, July 31, 2018 - 20:48

Puzzle 1115 seems to have a scoring problem.

After a client crash due to "asymmetry introduced by ActionLocalMinimize" while Acid Tweeking (yes I verified that debug.txt was updated at the time of the crash), my evolver score showed as 13621. Actually, it had been 13621 for a while, but the recipes were not seeing it.

There was an autosaved credit best showing 13621, but when I opened it, it loaded as 13606. I then did a "restore credit best", which set the score to 13616, which was the last thing reported by my recipe before the crash.

Maybe it's to be expected, but the Manage Solutions window is no longer showing the 13621 credit best autosave. The credit best autosave is now 13616, with a recent best autosave of 13617. Both these load at the same score, 13616.791.

This seems like a new wrinkle on a familiar problem. The client is now smart enough to eliminate the evidence. Next it will get a good lawyer.

(Thu, 07/23/2015 - 08:12  |  10 comments)


Joined: 04/24/2014
Groups: None

Added (scoring, autosave), as "strange" wasn't as descriptive as I'd hoped. :)

LociOiling's picture
User offline. Last seen 1 hour 33 min ago. Offline
Joined: 12/27/2012
Groups: Beta Folders

Maybe you update the title on http://fold.it/portal/node/2000613 as well, something like "auto structures tool creates spurious ligand".

Joined: 04/24/2014
Groups: None

Done, always glad to help clarify to get people to search easier/add more info to topics!

jeff101's picture
User offline. Last seen 7 hours 2 min ago. Offline
Joined: 04/20/2012
Groups: Go Science

It sounds like crashes for other symmetry puzzles described in
http://fold.it/portal/node/2000404 which gave messages like below:

"ERROR: asymmetry introduced by ActionIdealize"

"ERROR: asymmetry introduced by ActionGlobalMinimize"

I wonder if Random Idealize 1.8 (http://fold.it/portal/recipe/100243) or
Rav3n_pl Simple Idealize v1 (http://fold.it/portal/recipe/100680)
will crash in puzzle 1115 like they did in http://fold.it/portal/node/2000404 above.

SKSbell's picture
User offline. Last seen 33 weeks 18 hours ago. Offline
Joined: 12/01/2008
Groups: None

Similar issue? I load my credit best solution (which is all loops.) All filters enabled. Once I add even 1 segment of sheet or helix, actions such as rebuild, wiggle, etc. send the solution into red line. If I run filters (which are all still enabled) it goes out of red line, but can't get the credit best solution back without reloading. I did use auto structures at one point on this solution. Argh....

LociOiling's picture
User offline. Last seen 1 hour 33 min ago. Offline
Joined: 12/27/2012
Groups: Beta Folders

SKSbell, are you seeing this behavior on 1115 or 1117?

Is the red line through the score caused by filters being disabled?

The auto structures tool probably changed the last segment into a ligand (secondary structure type "M" for molecule). Some recipes will skip a ligand. See the case of The Spurious Ligand.

The ligand shows up as a white segment with EnzDes coloring. My Lig Detector recipe is another way to find a ligand.

To remove the ligand, use "Reset Structures" from the undo menu. Auto structures usually works OK if you select all segments, then deselect the last segment. In a couple of cases, I've seen auto structures change the last segment even when I thought it was not selected, so be sure to check your results.

SKSbell's picture
User offline. Last seen 33 weeks 18 hours ago. Offline
Joined: 12/01/2008
Groups: None

It was 1115. Filters were not disabled when the score was red-lined.

I did the reset structures and that took care of it.

LociOiling's picture
User offline. Last seen 1 hour 33 min ago. Offline
Joined: 12/27/2012
Groups: Beta Folders

OK, I hit the scoring issue again on 1115, on the evo side.

My credit score shows at 13658. There was a credit best auto save at that score, which I've uploaded for scientists as "BAD LOAD Autosaved Credit Best Evolver Solution". It shows loads as 13640.836.

Loading this solution erases the 13658 credit best, and the new credit best solution is only 13640.

LociOiling's picture
User offline. Last seen 1 hour 33 min ago. Offline
Joined: 12/27/2012
Groups: Beta Folders

H'mmm must proofread better, previous 2nd paragraph should read "it shows a score of 13658, but loads as 13640".

LociOiling's picture
User offline. Last seen 1 hour 33 min ago. Offline
Joined: 12/27/2012
Groups: Beta Folders
Status: Open » Closed

Old, closing.

Sitemap

Developed by: UW Center for Game Science, UW Institute for Protein Design, Northeastern University, Vanderbilt University Meiler Lab, UC Davis
Supported by: DARPA, NSF, NIH, HHMI, Amazon, Microsoft, Adobe, RosettaCommons