Experimental view menu not proper

Case number:954892-2004796
Topic:Developer Preview
Opened by:Timo van der Laan
Status:Open
Type:DevPrev Issue
Opened on:Saturday, February 10, 2018 - 09:34
Last modified:Monday, February 12, 2018 - 07:15

Trying to open the view menu in selection mode and it is a mess.
And the screenshot I made of it also looks funny.
http://fold.it/portal/files/chatimg/irc_308854_1518255030.png
Why is there that blue thing in the left of the screen, covering part of the view menu that was visible.

Working on windows 10.

(Sat, 02/10/2018 - 09:34  |  3 comments)


Joined: 09/21/2011
Groups: Void Crushers

Restarted the game and now it looks fine. Strange.

brow42's picture
User offline. Last seen 5 hours 23 min ago. Offline
Joined: 09/19/2011
Groups: None

The blue thing is because foldit dual-purposes the screen bitmap memory with the low-resolution "click map" to handle mouse clicks. There's some sort of lack of locking or race condition between rendering the view and writing out the screenshot. Fixing this is at the bottom of the priority list. I don't know why the click map can't just have its own memory.

jflat06's picture
User offline. Last seen 2 days 9 hours ago. Offline
Joined: 09/29/2010
Groups: Window Group

I believe this is what's going on. This bug has existed for as long as I can remember.

Sitemap

Developed by: UW Center for Game Science, UW Institute for Protein Design, Northeastern University, Vanderbilt University Meiler Lab, UC Davis
Supported by: DARPA, NSF, NIH, HHMI, Microsoft, Adobe, RosettaCommons