Won't run on Ubuntu

Started by callowschoolboy

callowschoolboy Lv 1

I'm running Lucid Lynx (Ubuntu 10.04) on my laptop and I can't get FoldIt to run. I try just double clicking the executable, nothing happens; I right click and choose Open, nothing happens; I even tried in a terminal, in the directory that all my FoldIt files are in, running it like a shell script (I didn't know what to use so I just did . Foldit)
I read some other threads but none answered my question, some referenced some libraries like ia32-libs but I couldn't apt-get them.

callowschoolboy Lv 1

Like I said, I tried in the console using just ". Foldit" and got "bash: .: Foldit: cannot execute binary file" so I figured it doesn't run like a shell script but I don't know what else to use.

Rav3n_pl Lv 1

I`m not 100% sure but mine ubuntu missing libgl.so
After installing it foldit runs properly.
Try unpack foldit again and run from console. Should show error.

callowschoolboy Lv 1

I messaged Judecca and he solved it very effectively:

1) use the command "./Foldit" to run it, not like I was doing
2) the library I needed (libglut.so.3) was gotten using "sudo apt-get install freeglut3"

Thanks Judecca!

mike-g2 Lv 1

I'm actually having problems using Karmic. I can get the binary to run up to the login point, but it doesn't allow me to enter a username (password yes, username no).

Anyone else seen something like this?

Mike

Shadowduck Lv 1

I also had problems getting Foldit to run on Ubuntu Lucid, solved by installing freeglut3.

Searching the Wiki gives the impression the software should "just work"… Since the lack of libglut.so.3 seems to be common, wouldn't it be an idea to make this information a little more prominent (or better still, fix the problem)?