REDHAT 5.5: Could not load library: /lib/libc.so.6: version `GLIBC_2.7' not found

Started by rashvar

rashvar Lv 1

Hi all,

I have a problem to run foldit on a redhat 5.5 machine. I get the following error:
"Foldit Error: Could not load library: /lib/libc.so.6: version `GLIBC_2.7' not found (required by cmp-binary-c8003abbbace63be438e1d275a08abfa/game_library.so)."

Is there a way to solve this problem?

Many thanks.

By the way, I could not find a search function for this forum. Am I blind?

Regards.

keith Lv 1

I have a RHEL 5.5 machine, have recently updated all packages with yum update, and I get the same exact error.

The most recent glibc is 2.5 on RHEL/CentOS systems. I think this might be related to them using 2.6.18 kernels from some quick googling. Is there a workaround for this to get Foldit running?

$ sudo yum install glibc
Loaded plugins: rhnplugin, security
Setting up Install Process
Package glibc-2.5-49.i686 already installed and latest version
Nothing to do