script edit changes lost

Started by jandersonlee

jandersonlee Lv 1

I recently switched to running the Beta version to us the Lua v2 script interface. Mostly it seems to be fine, but on a couple of occasions lately I've had it lose scripting edit changes.

In one case I was repeatedly using a Save/Close/Run/Edit cycle on a v2 script. This worked fine for over an hour and then all of a sudden when I tried to do SaveAs instead of Save to checkpoint the changes to a new version of the script it (a) did not create the newly named script and (b) lost about an hour's worth of edit changes that I had been seeing and running with.

A similar event happened yesterday, where it did not save a new version of a script, causing me to lose all of the changes I had made in that (long) edit session.

I have not experienced similar problems editing v1 scripts under the main branch client.

Rav3n_pl Lv 1

Use external editor and store your lua files totally outside.
Until editor and cookbook will be fixed it can happen.
Also, you need to be in "old" (not selection) interface to cookbook update and "catch" new recipe.

jandersonlee Lv 1

I can handle a work around.

The trouble is I have not figured how to capture a script out of the Cookbook editor. I know that ctrl-V can be used to paste a script edited externally, but how do I export one out begin modifying it? Is there a way (in the PC client) to so SelectAll+Copy to get a script onto the clipboard? With out that I'm stuck writing my own scripts or begging other Group members with Mac clients to copy scripts and PM or email them to me.

Thanks again.

bertro Lv 1

Just make sure your cursor is in the editor box, then do Ctrl-A and Ctrl-C. Now you can paste the editor text with Ctrl-V into your favorite external editor.

Regards