install fails on OpenSuSE Leap

Case number:845829-2008296
Topic:Crash/Hang
Opened by:rws
Status:Open
Type:Bug
Opened on:Wednesday, November 20, 2019 - 08:18
Last modified:Thursday, November 21, 2019 - 14:17

After unpacking, starting, resources are downloaded and then it bails out with:

ralf@ark:~/Foldit> ./Foldit
Foldit Error: Could not load library: /lib64/libm.so.6: version `GLIBC_2.27' not found (required by cmp-binary-23770c602d2a5249bcfb0463fef9a6ec/game_library.so).

I also did:

ralf@ark:~/Foldit> ldd cmp-binary-23770c602d2a5249bcfb0463fef9a6ec/game_library.so

ldd: warning: you do not have execution permission for `cmp-binary-23770c602d2a5249bcfb0463fef9a6ec/game_library.so'
cmp-binary-23770c602d2a5249bcfb0463fef9a6ec/game_library.so: /lib64/libm.so.6: version `GLIBC_2.27' not found (required by cmp-binary-23770c602d2a5249bcfb0463fef9a6ec/game_library.so)
linux-vdso.so.1 (0x00007ffd86be1000)
libGL.so.1 => /usr/lib64/libGL.so.1 (0x00007f6404b75000)
libGLU.so.1 => /usr/lib64/libGLU.so.1 (0x00007f6404908000)
libglut.so.3 => /usr/lib64/libglut.so.3 (0x00007f6404651000)
librt.so.1 => /lib64/librt.so.1 (0x00007f6404449000)
libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007f6404108000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007f6403f04000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f6403ce6000)
libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f640395c000)
libm.so.6 => /lib64/libm.so.6 (0x00007f6403624000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f640340c000)
libc.so.6 => /lib64/libc.so.6 (0x00007f6403052000)
/lib64/ld-linux-x86-64.so.2 (0x00007f640d4aa000)
libGLX.so.0 => /usr/lib64/libGLX.so.0 (0x00007f6402e20000)
libGLdispatch.so.0 => /usr/lib64/libGLdispatch.so.0 (0x00007f6402b6a000)
libXrandr.so.2 => /usr/lib64/libXrandr.so.2 (0x00007f640295f000)
libXxf86vm.so.1 => /usr/lib64/libXxf86vm.so.1 (0x00007f6402759000)
libXi.so.6 => /usr/lib64/libXi.so.6 (0x00007f6402548000)
libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007f640231f000)
libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007f640210d000)
libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00007f6401f03000)
libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007f6401cff000)

(Wed, 11/20/2019 - 08:18  |  2 comments)


bkoep's picture
User offline. Last seen 2 hours 54 min ago. Offline
Joined: 11/15/2012
Groups: None

Yes! This is a known issue, and we just (today!) released a fix for it. You may need to download Foldit again from the front page, but the new download should be compatible with older versions of GLIBC.

Please let us know if you continue to have problems!

rws's picture
User offline. Last seen 3 weeks 12 hours ago. Offline
Joined: 08/13/2008
Groups: Go Science

OK, now it starts and bails out with:

terminate called after throwing an instance of 'std::logic_error'
what(): basic_string::_S_construct null not valid
Aborted (core dumped)

But then on second attempt it starts leaving warnings on the console:

Foldit Error: The game has previously not started up correctly.
If this problem persists, please install the latest version.
AL lib: (EE) ALCplaybackOSS_open: Could not open /dev/dsp: No such file or directory
AL lib: (WW) alcSetError: Error generated on device (nil), code 0xa004
AL lib: (WW) ALCplaybackOSS_open: Could not find "Generic Software" in device list
AL lib: (WW) alcSetError: Error generated on device (nil), code 0xa004

which is about audio I believe. The game runs fine on first glance however, even on this machine without graphics card.

Sitemap

Developed by: UW Center for Game Science, UW Institute for Protein Design, Northeastern University, Vanderbilt University Meiler Lab, UC Davis
Supported by: DARPA, NSF, NIH, HHMI, Amazon, Microsoft, Adobe, RosettaCommons