First try with devprev update on Mac

Case number:954892-2003579
Topic:Developer Preview
Opened by:actiaslunaIRC
Status:Open
Type:DevPrev Issue
Opened on:Tuesday, March 14, 2017 - 23:06
Last modified:Sunday, April 9, 2017 - 15:50

While I certainly appreciate that the foldit folks are working to find a solution for Mac client issues,
the latest Devprev release is ...not optimal... here's what I mean:
I get the game_dynamic in the finder bar.
The game for non-monomer Blueprint tool puzzles opens fine.
HOWEVER... I get a gray game window with "No Tool" in the top left,
And in the middle of the screen a black dialog box with
"Unknown filter type: ResidueCountScore"
the red x button with "Close" beneath it.

Attaching a .png of that screen.

Devprev update:
20170313-6f530cd180-osx_x86-devprev

This same thing happened in El Capitan (just before I realized I should update it)
and in Sierra (OS 10.12.3)

Still on this hardware setup:
Model Name: iMac
Model Identifier: iMac17,1
Processor Name: Intel Core i7
Processor Speed: 4 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 32 GB
Boot ROM Version: IM171.0105.B15
SMC Version (system): 2.34f2
AMD Radeon R9 M395X 4096 MB graphics

SOOOO... I'M BACK TO THE WINDOWS environment 'til the next update comes out.
Le sigh. Thank you foldit for trying though!

AttachmentSize
ScreengrabinDevprevFoldit.png156.85 KB
(Tue, 03/14/2017 - 23:06  |  20 comments)


Joined: 03/05/2015
Groups: Gargleblasters

For the record, I also get the same message with the Windows client devprev update latest version
20170310-87e0fc5180-win_x86-devprev

And a question: Was there a recent update to the downloadable Windows foldit installer (or a "hotfix" - that I missed? Because the client for download used to be able to open monomers (prior to update before last?) and I noticed that without updating it I could no longer run the monomers (Noticed yesterday that they would load and crash, or crash at first working, this in Windows). If I could roll back to the previous I would. I have only one other "legacy" client that will open the monomers that I keep having to watch like a hawk so that it doesn't update either. I noticed that the most recent download version is perhaps dated 20170210? Whatever version is the latest download (not the latest update) though, definitely doesn't allow me to run the monomers... they simply crash.

Susume's picture
User offline. Last seen 1 hour 24 min ago. Offline
Joined: 10/02/2011

On Win 7 with new devprev update, I also can't load puzzle 1352 (monomer design). When I try to load it I get a popup message saying "Unknown filter type: ResidueCountScore" with a "Close" button. This did not crash the client, but since it was the first puzzle I tried to load the screen was left in an unusable state (no menus showing) and I had to close it.

20170310-87e0fc5180-win_x86-devprev

Puzzle 1351 (revisit) loads fine.
Puzzle 1353 (denovo) loads fine.
I don't have puzzle 1350 (contacts) in this folder, but I tried to load an old contact puzzle (1261) that I do have, and got the message "Files with unrecognized extensions specified: .ocontacts" (same as Bertro's feedback on 1350: http://fold.it/portal/node/2003581). This did not crash the client, just would not load the puzzle.
An old design puzzle (1260) gets the same error as 1352 and does not load but also does not crash.

So both design puzzles and contact puzzles do not work with this update.

Joined: 03/05/2015
Groups: Gargleblasters

I got the same message as Susume and Bertro when I tried to load puzzle 1350 in the hotfixed devprev client just now. But the monomer works now that the hotfix is in place

Joined: 03/05/2015
Groups: Gargleblasters

(The above on my Mac client, Sierra 10.12.3)

jflat06's picture
User offline. Last seen 41 min 45 sec ago. Offline
Joined: 09/29/2010
Groups: Window Group

It looks like there's some code that got unintentionally removed with this update. We'll deploy a hotfix to get it back in.

Joined: 03/05/2015
Groups: Gargleblasters

jflat - Thanks for the quick update on status. Will be glad when you post that the hotfix is done as I am eager to see if it helps with my Mac OS client. (and how it runs in WIndows 10 as well since I'm kind of playing both, albeit not at the same time.)

Joined: 12/27/2012
Groups: Beta Folders

I'm seeing the same issue as Susume reported. Windows 10 in my case.

Joined: 12/27/2012
Groups: Beta Folders

Also, when I try to load 1352 with devprev, after the "unknown filter" dialog, I see "no tool" in the upper left-hand corner. The client crashes with an unhandled exception when I try to do anything. (Clicking on the background is enough.)

Joined: 12/27/2012
Groups: Beta Folders

After taking the hotfix, puzzle 1352 opens, but old puzzle 1234 gives:

"File with unrecognized extensions specified: .ocontacts."

Followed by "no tool" and client crash.

I'll try again later with a more recent client, to get more recent contact puzzle, haven't used this test client in a while.

Joined: 03/05/2015
Groups: Gargleblasters

Ran update for Windows client and it's working fine with the monomer puzzle. Will test Mac OS tonight along with the contact puzzles in both Mac and Windows

Joined: 03/05/2015
Groups: Gargleblasters

While I'm away from the computer today I'll also run a recipe that runs fine for other puzzles but has been crashing the monomer (crashing both Mac and Windows versions), and see how it goes in the devprev update

Joined: 05/11/2015
Groups: Gargleblasters

Just loaded *successfully* the monomer in my Mac client devprev hot fixed version... am letting it run and will see what happens if I "push" it with something that has recently been crashing. Opportunity for a "yay" or at least a preliminary "woohoo"? We shall see. Amusingly, game_dynamic still showing in finder bar.

Joined: 03/05/2015
Groups: Gargleblasters

Still running (but my Mac "conveniently" slept last night instead of running, sigh, the oh so "helpful" default energy saver was on. I need to find an old all.macro file because in devprev I can't load recipes, and the recipes that loaded with the all.macro aren't all the problematic ones that crashed in the old main client.. (unable to load recipes in devprev...feature or bug?) But so far, so good.

Joined: 03/05/2015
Groups: Gargleblasters

(recipes "problem" fixed, I just copied the all.macro file from my "BOOTCAMP" drive foldit files over into the devprev Mac folder resources folder.)

Joined: 03/05/2015
Groups: Gargleblasters

Have been running Mac client with one of the DRemixW scripts on the monomer all day... these were crashing at some point early on in the previous Mac main client and are apparently working fine now. No crashes on either client so far through the day with anything I've tried. So on the monomer, so far this is testing well.

Joined: 03/05/2015
Groups: Gargleblasters

Not an unexpected one, but a first crash for one of the monomer clients running devprev. Actually got farther than expected before it crashed on a group recipe (that often crashes badly on the monomers).

Thread 4 crash

Log (mac log) attached, but "highlight"

Thread 4 crashed with X86 Thread State (32-bit):
eax: 0x00000000 ebx: 0x00000003 ecx: 0xb09df1dc edx: 0x00000000
edi: 0xb09e2000 esi: 0x00000006 ebp: 0xb09df208 esp: 0xb09df1dc
ss: 0x00000023 efl: 0x00000296 eip: 0x9f8b749a cs: 0x0000000b
ds: 0x00000023 es: 0x00000023 fs: 0x00000023 gs: 0x0000000f
cr2: 0xa5326320

Logical CPU: 0
Error Code: 0x00080148
Trap Number: 132

Joined: 03/05/2015
Groups: Gargleblasters

Addendum to the above...Just noting that all other recipes (that you would run on a no rebuild monomer puzzle) are working fine and no other crashing. So for me, the monomer puzzles issue is apparently fixed by the hotfixed update.

jflat06's picture
User offline. Last seen 41 min 45 sec ago. Offline
Joined: 09/29/2010
Groups: Window Group

Thanks for the feedback, actiasluna.

It sounds like maybe the recent update has at least helped matters, then?

Joined: 03/05/2015
Groups: Gargleblasters

Yes, fewer if any crashes just running the monomer without recipes... that said, though, still crashy on recipes it shouldn't have problems with. Thread 4 (a thread that crashed very frequently when things were at their worst) again. Better, but not yet "better enough."

Joined: 03/05/2015
Groups: Gargleblasters

Note that there are still "double free" crashes with the devprev and main latest Mac... see my other feedback thread on 1361 for mac crashlog info. (these are... I think all either thread 10 or 0 crashes...)

Sitemap

Supported by: UW Center for Game Science, UW Department of Computer Science and Engineering, UW Baker Lab, VU Meiler Lab,
DARPA, NSF, NIH, HHMI, Microsoft, Adobe, RosettaCommons